logo.JPG (15141 bytes)

IB INSTALLATION TO BE USED
WITH FIBONACCI TRADER

 

CLICK HERE TO WATCH VIDEO WITH DETAILED INSTALLATION INSTRUCTION
YOU WILL USE THE LINKS ON THIS PAGE AND THEY ARE USED IN THE VIDEO

IF TWS AND FT ARE RUNNING ON DIFFERENT MACHINES YOU MUST UPDATE THE API ON BOTH MACHINES.

Using IB data - get correct IB API.

For the Fibonacci Trader 4 version R108, Fibonacci Trader 4.10 or later use IB API 9.71 and TWS 946 or later.

Close all programs.

You must have Fibonacci Trader 4.00 R108 or later installed.

Fibonacci Trader needs the API 9.71 and the TWS 946 version or later.

First, if you do not have the TWS installed go to www.interactivebrokers.com, download and install it. YOU MUST INSTALL THE STAND ALONE VERSION OF TWS, NOT THE BROWSER VERSION. YOU MUST INSTALL THE TWS BEFORE YOU INSTALL THE API FILE BELOW.

Second, download and install the correct API for this Fibonacci Trader version from HERE.

Third, if you do not have the Fibonacci Trader version r108 or later that can be download and install from HERE (IF YOU ARE USING THE 30 DAY TRIAL DO NOT INSTALL THIS, INSTALL THE TRIAL VERSION)

Forth, If you install the API 9.68, FT r102 version and your Client for IB window does not come out is because some machine need to install some Microsoft files that are not on the IB API installation, this is the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86), click here to download and install these files, after you install that reinstall the API 9.68 to have a correct installation.

Please check how are the Symbols Format using IB.

 

 

For the Fibonacci Trader version R104 or later use IB API 9.68 and TWS 940 or later. Previous FT version R103 will not work correctly with TWS 940 or later.

Close all programs.

You must have Fibonacci Trader 4.00 R104 or later installed.

Fibonacci Trader needs the API 9.68 and the TWS 940 version or later.

First, if you do not have the TWS installed go to www.interactivebrokers.com, download and install it. YOU MUST INSTALL THE STAND ALONE VERSION OF TWS, NOT THE BROWSER VERSION. YOU MUST INSTALL THE TWS BEFORE YOU INSTALL THE API FILE BELOW.

Second, download and install the correct API for this Fibonacci Trader version from HERE.

Third, if you do not have the Fibonacci Trader version r104 or later that can be download and install from HERE (IF YOU ARE USING THE 30 DAY TRIAL DO NOT INSTALL THIS, INSTALL THE TRIAL VERSION)

Forth, If you install the API 9.68, FT r102 version and your Client for IB window does not come out is because some machine need to install some Microsoft files that are not on the IB API installation, this is the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86), click here to download and install these files, after you install that reinstall the API 9.68 to have a correct installation.

Please check how are the Symbols Format using IB.

 

For the Fibonacci Trader version R101 or early use IB API 9.68 and TWS 938 or later.

Close all programs.

You must have Fibonacci Trader 4.00 R101 or later installed.

Fibonacci Trader needs the API 9.68 and the TWS 938 version or later.

First, if you do not have the TWS installed go to www.interactivebrokers.com, download and install it. YOU MUST INSTALL THE STAND ALONE VERSION OF TWS, NOT THE BROWSER VERSION. YOU MUST INSTALL THE TWS BEFORE YOU INSTALL THE API FILE BELOW.

Second, download and install the correct API for this Fibonacci Trader version from HERE.

Third, if you do not have the Fibonacci Trader version r101 or later that can be download and install from HERE (IF YOU ARE USING THE 30 DAY TRIAL DO NOT INSTALL THIS, INSTALL THE TRIAL VERSION)

Forth, If you install the API 9.68, FT r101 version and your Client for IB window does not come out is because some machine need to install some Microsoft files that are not on the IB API installation, this is the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86), click here to download and install these files, after you install that reinstall the API 9.68 to have a correct installation.

Symbols Format

 

For the Fibonacci Trader version R89 or later use IB API 9.60 and TWS 893 or later.

Close all programs.

You must have Fibonacci Trader 4.00 R89 or later installed.

Fibonacci Trader needs the API 9.60 and the TWS 893 version or later.

First, if you do not have the TWS installed go to www.interactivebrokers.com, download and install it.

Second, download and install the correct API for this Fibonacci Trader version from HERE.

Third, if you do not have the Fibonacci Trader version r89 can be download and install from HERE (IF YOU ARE USING THE 30 DAY TRIAL DO NOT INSTALL THIS r89, INSTALL THE TRIAL VERSION)

Forth, If you install the API 9.60, FT r89 version and your Client for IB window does not come out is because some machine need to install some Microsoft files that are not on the IB API installation, this is the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86), click here to download and install these files, after you install that reinstall the API 9.60 to have a correct installation.

 

For the Fibonacci Trader version R87 or later use IB API 9.51 and TWS 886 or later.

Close all programs.

You must have Fibonacci Trader 4.00 R87 or later installed.

Fibonacci Trader needs the API 9.51 and the TWS 886 version or later.

First, if you do not have the TWS installed go to www.interactivebrokers.com, download and install it.

Second, download and install the correct API for this Fibonacci Trader version from HERE.

Third, if you do not have the Fibonacci Trader version r87 can be download and install from HERE (IF YOU ARE USING THE 30 DAY TRIAL DO NOT INSTALL THIS r87, INSTALL THE TRIAL VERSION)

Forth, If you install the API 9.51, FT r87 version and your Client for IB window does not come out is because some machine need to install some Microsoft files that are not on the IB API installation, this is the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86), click here to download and install these files, after you install that reinstall the API 9.51 to have a correct installation.



For the Fibonacci Trader until version R81 use API 9.20

Close all programs.

You must have Fibonacci Trader 4.00 R81 or later installed.

Click on Start, Settings, Control Panel, Add or Remove Programs and remove the TWS Interoperability Components, that is the TWS API that you will be uninstalling.

Delete file C:\JTS\ACTIVEX\TWS.OCX

Fibonacci Trader needs the API 9.20 and the TWS 877.8, download and install the API from

http://www.fibonaccitrader.com/IB/API920.exe, the TWS download and install from IB web site.

If after that you still have a problem, uninstall your IB software and the API again, and then install all again.

 

For the Fibonacci Trader version until R74

Close all programs.

You must have Fibonacci Trader 4.00 R74 or later installed.

Click on Start, Settings, Control Panel, Add or Remove Programs and remove the TWS Interoperability Components, that is the TWS API that you will be uninstalling.

Delete file C:\JTS\ACTIVEX\TWS.OCX

Fibonacci Trader needs the API 9.00 and the TWS 865, download and install the API from

http://www.fibonaccitrader.com/IB/API900.exe, the TWS download and install from IB web site.

If after that you still have a problem, uninstall your IB software and the API again, and then install all again.

 


Trading any market carries a high level of risk, and may not be suitable for all investors. The high degree of leverage can work against you as well as for you. Before deciding to invest you should carefully consider your investment objectives, level of experience, and risk appetite. The possibility exists that you could sustain a loss of some or all of your initial investment and therefore you should not invest money that you cannot afford to lose. You should be aware of all the risks associated with trading, and seek advice from an independent financial advisor if you have any doubts.

* The Views and opinions represented in the provided website links and resources are not controlled by the Referring Broker or the FCM.  Further, the Referring Broker and the FCM are not responsible for their availability, content, or delivery of services.

Privacy Policy | Contact Information

Copyright 1996-2017 Fibonacci Trader Corp.
All names mentioned in this document are trademarks or registered trademarks of their respective owners.